Product Updates - June 2018

Overview of Changes

Component Type Notes
Any Dashboard New Feature A new Copy Dashboard option now appears on every dashboard overflow menu.
See Copy Dashboard.
Data Visualization, KPI Visibility,
Statistical Process Control, and Raw Data Monitoring pages
New Feature The new Save button automatically creates a new widget when you create a new dashboard or save to an existing dashboard.
See Save Charts to New and Existing Dashboards.
AI Data Pipeline Enhancement The new Advanced Editor button appears in any model in the AI Data Pipeline, and lets you edit the configuration file directly.
See AI Data Pipeline - Advanced Editor.
Data Visualization and Data Table pages Enhancement You can now instantly convert Cycle Times to different units in Data Visualizations or Data Tables.
See Cycle Time Unit Conversion.

New Features

Copy Dashboard

To help accelerate the creation of new dashboards, we built the new Copy Dashboard capability.

On any dashboard, click the overflow menu in the upper-right, and then click Copy Dashboard. A new dashboard opens with “Copy of” inserted into the title, and all of the widgets are copied as well. You can also copy any dashboard that other users have shared as Public.

Save Charts to New and Existing Dashboards

To facilitate the addition of new widgets onto new and existing dashboards, we have created the save chart capability.

On Data Visualization, KPI Visibility, Statistical Process Control, and Raw Data Monitoring pages, after creating a visualization, click the Save button. A new widget is automatically created when you click either:

  • Add a New Dashboard
  • Add to Existing Dashboard


Enhancements

AI Data Pipeline - Advanced Editor

In any model (Facility, Machine Type, or Machine) in the AI Data Pipeline, the new Advanced Editor button appears in the upper-right.

Click the Advanced Editor button to toggle the model editor into Advanced Mode.

On the Advanced Mode page, you can edit the configuration file directly.

When you make changes, several layers of validation run. The first checks that your configuration can be parsed properly. If it cannot be parsed, a JSON Error appears in the console, and the auto-save feature and Deploy button become disabled.

Additional layers of validation that flag issues in the configuration file allow for auto-saving, but disable the Deploy button.

Cycle Time Unit Conversion

You can now instantly convert Cycle Times to different units in the following locations:

  • Data Visualizations: X-Axis and Y-Axis labels
  • Data Visualizations: Add Filter menu
  • Data Tables: Column header

On any Data Visualization page, on an axis label, click the displayed units (i.e., Seconds, Hours, etc.), and then select a new option.

On any Data Visualization page, on the Add Filter menu, click Cycle Time, and then make a selection in the new Units drop-down list.

On any Data Table page, under a Cycle Time column header, select the new units from the drop-down list.